A fix has been implemented and we are monitoring the results.
Posted Nov 25, 2025 - 14:43 CET
Update
We are continuing to investigate this issue.
Posted Nov 25, 2025 - 12:11 CET
Investigating
We currently experience performance issues. Our engineers are already investigating the root cause. We will keep you informed about the status.
Posted Nov 25, 2025 - 12:08 CET
This incident affected: ServiceConnect® (Portal, Client Applications, Smarttest) and Dräger Connect (Portal, Alarm History Analytics, Device Utilization Analytics, Gas Consumption Analytics, Lung Protective Ventilation Analytics - Anesthesia, OR Companion, Service Tracking, Service Request, Service Reports, Documents, Parts, myDevices).