Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 03, 2025 - 08:00 CET
Scheduled
Our system engineers will perform an update on the service. The application won't be fully available during the update process. We will inform you when all update tasks are completed.
Posted Dec 02, 2025 - 14:09 CET
This scheduled maintenance affected: Dräger Connect (Device Utilization Analytics).